当前位置: 首页 > Python > 正文

python安装numpy和pandas

最近要对一系列数据做同比比较,需要用到numpy和pandas来计算,不过使用python安装numpy和pandas因为linux环境没有外网遇到了很多问题就记下来了。首要条件,python版本必须是2.7以上。

linux首先安装依赖包

windows安装pip即可,具体方法参考pip官网 http://pip-cn.readthedocs.io/en/latest/installing.html

1、 pip方式安装

如果有外网一般推荐使用pip安装,linux下和windows下均可使用pip安装

但很快就会发现这些源安装超级慢,所以我推荐大家使用豆瓣的源

2、如果服务器上没有外网使用不了pip,则需要使用源码安装。推荐大家在豆瓣pypi下载,速度更快  https://pypi.doubanio.com/simple/?allow_list_dir=1

python numpy安装包下载地址是 https://pypi.python.org/pypi/numpy/,pandas的安装包下载地址是 https://pypi.python.org/pypi/pandas,github地址是 https://github.com/pandas-dev

 

如提示缺少 setuptools 则从https://pypi.python.org/pypi/setuptools下载 setuptools安装。

安装pandas会提示 ImportError: Building pandas requires cython则需要安装Cython或者升级Cython先,下载链接 https://pypi.python.org/pypi/Cython/ 。windows下pip安装如下

linux下可使用yum安装或者pip安装

如果需要更新到最新版本的Cython则下载源码后安装

然后是按照pandas

如果遇到需要安装 python-dateutil的提示则是该库版本过低。先下载six最新版本1.9.0(下载地址),然后更新 python-dateutil到新版本2.5.3版本(下载地址)。

最后运行如果出现 /usr/lib64/libstdc++.so.6: ELF file OS ABI invalid的错误则将 /usr/lib64/libstdc++.so.6软链指向低版本的 libstdc++.so.6.0.8,不要指向高版本 libstdc++.so.6.0.20。

至此就安装成功了。

总结,花了一上午安装这个主要是因为下载源慢,依赖包多。所以建议大家都是用pypi豆瓣源,直接在simple下面搜你需要的安装包。

原创文章,转载请备注原文地址 http://www.cnblogs.com/lxmhhy/p/6029465.html

本文固定链接: http://t.yjsec.com/index.php/2018/03/22/501/ | 下一站

该日志由 admin 于2018年03月22日发表在 Python 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: python安装numpy和pandas | 下一站

python安装numpy和pandas:目前有1 条留言

  1. 沙发
    admin:

    MacOS下安装:
    pip install pandas –user -U
    pip install scipy –user -U
    pip install lxml –user -U
    pip install tushare –user -U
    pip install bs4 –user -U

    2018-03-22 上午11:02 [回复]

发表评论

快捷键:Ctrl+Enter